By using seoforum’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the best UK dedicated SEO Forum

    Provide or get advice on everything SEO, ask questions, gain confirmation or just become apart of a friendly, like minded community who love SEO and Online Marketing.


    Join 50,000 members!

Cloaking Issue But Can't See Where?

M

MaxRobrts

New Member
Hi, I have a question that hopefully someone here could uncover. Basically, a friend's Google Ads account was suspended for 'cloaking'. I've searched on his main website (he's a dentist) that the traffic was going to but cannot see what is causing Google to think that cloaking is occurring. I have decent SEO knowledge but not enough to understand where Google is seeing cloaking.

I've put the site into a few cloaking testing tools and it gets flagged as cloaking there too.

Wondering if anyone is able to tell what the issue is? I don't know if the web designer did something, or if some SEO company he hired has done something?

Website is: ipswichdentalsurgery .co.uk

Thanks, any help is much appreciated.
 
Community

Community

Administrator
Staff member
I've seen this quite alot recently, primarily with a particular Web designer creating hundreds of local landing pages, all of which redirect to the homepage for a normal user, but display inaccessible to other useragents.

I'm actually quite interested in what is happening here, if your friend doesnt mind giving access for someone to check it out, feel free to private message me and ill send you my email address.
 
Community

Community

Administrator
Staff member
So we've narrowed this issue down to only affecting siteground hosting customers

It looks like it could be isolated to bots that site grounds AI believes are not real :


I'm assuming that the Google adwords bot, isnt included or maybe has a different IP range of which Site grounds AI has configured.

I've tested a few other siteground sites using the Google bot as my user agent, and every siteground site i test results in the page not loading ( which is probably correct as i am in actual fact a fake google bot ) the problem is if an adwords rep was to manual approval of an ad/account it may seem like cloaking.

You can replicate this by installing a chome extention which allows you to browse as different user agents :


Change the user agent to Google bot, then browse to any website on siteground, the pages do not load. Browse any other website not on Siteground, everything loads perfectly fine.
 
Community

Community

Administrator
Staff member
Just to update, ive found a site which is using siteground, but instead of using sitegrounds DNS, they go via cloudflare. Their site doesnt flag as having cloaking issues. Could be an easy fix solution for your client/friend just to switch DNS to cloudflare instead
 

Latest posts

Latest Products

  • [Rivmedia] Lazy Loader XF2
    [Rivmedia] Lazy Loader XF2
    Load images asynchronously on your forum, allowing images to be loaded only when they are in view
    • Rivmedia
    • Updated:
  • [Rivmedia] Guest Redirect & Profile unlink
    [Rivmedia] Guest Redirect & Profile unlink
    Forums which prevent member profile access for guests, redirction and unlinking for profiles
    • Rivmedia
    • Updated:
  • [Rivmedia] Simple Redirects
    [Rivmedia] Simple Redirects
    Simple redirects allows forum admins to make simple 301 or 302 redirects via their admin panel
    • Rivmedia
    • Updated:
  • [Rivmedia] Minimum Message Length
    [Rivmedia] Minimum Message Length
    Eradicate short, pointless posts with a minimum message length and improving content worth on a thre
    • Rivmedia
    • Updated:
Top