By using seoforum’s services you agree to our Cookies Use and Data Transfer outside the EU.
We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters.

  • Join the best UK dedicated SEO Forum

    Provide or get advice on everything SEO, ask questions, gain confirmation or just become apart of a friendly, like minded community who love SEO and Online Marketing.


    Join 50,000 members!

Really need some advice with SEO not performing as expected

M

mungo2007

New Member
Hi all

Newbie here, i really need some help with the SEO on our website. ultrabeamlighting.co.uk

It is a wordpress website using the woocommerce plugin - been running for 2 years.

I have a reasonable knowledge of SEO but i just can't get the traffic to the site increasing we are only getting about 30 visitors a day currently with around 500 pages on the site.

My concern is that there is some sort of technical SEO issue that i don't have the talent for.

Here is an overview of what i have been doing

I am using the Yoast plugin and have been optimizing all of the pages (categories and product pages)

Lots of keyword research for the optimized pages targetting more of the lower hanging fruit rather than the high competition keywords.

Blogging 4-5 times a week using the keyword research for optimizing these.

Social activity posting articles and products.

Some white hat link building but not a huge amount trying to get this to come naturally with my content.

The only thing i can think that is the problem is some sort of technical issue but i really need someone with the knowledge to help, i don't mind paying for the help as long as it sorts the potential problem.

Thanks all
 
M

mungo2007

New Member
Hi

Yes i subscribe to Neil's blog didn't realize he had an analyser i will give this a try and see what it springs up

Thank you
 
Community

Community

Administrator
Staff member
I assume you used to have a redirect from an Old site given all the spammy blogspot backlinks pointing to the site ? or were previously pointing the site before the redirect stopped ?
 
M

mungo2007

New Member
Hi

Yes we did have a redirect how did you know that???

That does not sound good is it something that needs to be addressed? If so what do i do?
 
Community

Community

Administrator
Staff member
Hi

Yes we did have a redirect how did you know that???

That does not sound good is it something that needs to be addressed? If so what do i do?
When was it removed and was it removed due to poor quality backlinks being an issue ? Or any other SEO related issues ? deslamps looks to have been carrying a bit of authority even with the spammy blogspot links.

Content and activity is great, but ultimately backlinks still count especially when building your brands authority.
 
M

mungo2007

New Member
I think it was removed about 6 months ago just because of poor quality links

So is there anything you suggest i can do about this or do we just carry on now as we are and try to build the links on this domain.

Link building is not my strong area, i don't want to go down the black/grey hat route on one of these freelancer sites as this will ultimately have penalty with G
 
Community

Community

Administrator
Staff member
There are a few things you can improve on, such as your stacked redirects from https/http and www/non-www.

And your first time byte for performance, that could be related to your theme/scripts loaded or a poor hosting enviroment, not something I could advise on without looking at it in a proper audit.

Yes there is no point in looking at "cheap" seo services, those are never going to help increase brand visibility and promote growth.
 
M

mungo2007

New Member
Ok the redirects i have no idea on out of talent to sort that out so i would need to get my web guy to look into this.

Ok when you say performance do you mean site speed? If so this is something i have really worked on and google insights is saying speed is pretty good.
 
Community

Community

Administrator
Staff member
Actually looking at the performance issues, they are primarily to do with redirect stacks, and or mixed content/assets loading.

So your site is attempting to load http material while it should be loading https. This is often caused by absolute URL's in your theme or your Wordpress install not having a full search and replace for the old URL to the new.

Will PM you for more details.
 

Latest posts

Latest Products

  • [Rivmedia] Lazy Loader XF2
    [Rivmedia] Lazy Loader XF2
    Load images asynchronously on your forum, allowing images to be loaded only when they are in view
    • Rivmedia
    • Updated:
  • [Rivmedia] Guest Redirect & Profile unlink
    [Rivmedia] Guest Redirect & Profile unlink
    Forums which prevent member profile access for guests, redirction and unlinking for profiles
    • Rivmedia
    • Updated:
  • [Rivmedia] Simple Redirects
    [Rivmedia] Simple Redirects
    Simple redirects allows forum admins to make simple 301 or 302 redirects via their admin panel
    • Rivmedia
    • Updated:
  • [Rivmedia] Minimum Message Length
    [Rivmedia] Minimum Message Length
    Eradicate short, pointless posts with a minimum message length and improving content worth on a thre
    • Rivmedia
    • Updated:
Top